OBJ files lose textures/colours when importing or exporting

Hi,

I imported a lot of different 3D models into uMake and they all lost their textures and/or colours. Some had MTL files with them and some didn't. Same happened when I exported OBJ file from uMake to PS. 

 

I'm new to 3D modeling so this is propably due to my ignorance and that's why I didn't report it as a bug.

Hi,

I imported a lot of different 3D models into uMake and they all lost their textures and/or colours. Some had MTL files with them and some didn't. Same happened when I exported OBJ file from uMake to PS. 

 

I'm new to 3D modeling so this is propably due to my ignorance and that's why I didn't report it as a bug.

0
2 comments

Hi Jyrki, 

So uMake can import OBJ's with MTL files and their textures, but the file has to be zipped up in a zip file-- with the MTL file and all textures, texture maps, etc. 

Exporting an OBJ may strip the file of the textures at this time, but we are working hard on making OBJ's and OBJ export better and better, so while it may not work perfectly now, it will in the near future. 

 

I hope that helps. Just make sure when you import OBJ's with textures, that everything that is needed is in the file. Otherwise it may not work. What program are the files exported from? 

 

 

Hi,

 

thanks for the reply. 

 

Ok, so I'll wait :) Unfortunately it didn't work with ZIP file either. 

 

I don't know the program, because I bought those files from a website. Might be that the files have been made incorrectly, but they were quite expensive so I really hope they weren't :)

Please sign in to leave a comment.